Downloading Insurgence Problems

I apologize if this has been answered before, but I cannot seem to find any answers to my problems.

I’ve been having many troubles trying to download this game, which is a shame as it seems incredibly well put together and cool. Firstly, I tried to download this on my Macbook Pro, which is running macOS Sierra. I got the Insurgence application thing with the Wineskin Icon, but when I tried to open it nothing would seem to happen. I searched this problem and the closest thing I could find was this a forum and it didn’t help me very much. (I would include the link but apparently I am only allowed to use 2 links in a post.) I then looked at this: and downloaded Wineskin Winery. I tried to follow the steps, but the changes didn’t seem to stick. Nothing continued to happen when I opened the program. So I tried to download it on my Windows 10 computer.

I could download the launcher just fine. I opened it up, it appeared just fine, and it seemed everything was working for once. I started the download, and suddenly, part-way through, my anti-virus software (Kapersky) started popping up and talking about about some kind of malware. I looked at the report and it said there was something named PDM:Trojan.Win32.Generic in the application and just deleted everything. I looked up “Trojan” on these forums and I could see 2 replies to Announcing the Insurgence Launcher about this same thing, but no-one really seemed to notice. I haven’t actually tried to download just the core for Windows, but I would rather download the launcher because it seems that trying to keep your previous save in an update is much harder to do with the core, and I don’t want to mess around with save files. So if anyone knows anything about either of these problems, the help would be greatly appreciated.

Edit: tl:dr The program seems to do nothing on my Mac and there seems to be a Trojan virus on the Windows launcher. Help?

Edit (Another one already, Sorry.): I apparently I leveled up so here’s the link I couldn’t post before:

I’m on a Mac so these are for making it work on the Mac, someone else should help with the Windows.

What do you mean by “the changes didn’t seem to stick”?

You can try Porting kit.

First, download Porting Kit from Download the Mac Core. Unzip and open Porting Kit, and click Library on the top of the window and click “Add Application” near the top of the window. Select the Mac Core. Now, click the Wineskin icon and click play to play the game. If you don’t trust Porting Kit or if this doesn’t work, try another method.

Let me know if it works :wink:

I personally prefer wineskin because you can just open the application directly, so if you want to try to make that work, give more information we can try to help :slight_smile: (The first link you posted is probably the most referenced, it really should work, so if you don’t mind, could you say what the problem was even if you’re satisfied with Porting Kit?)

As for not wanting to get the core on your windows, the save file is stored separately in a completely different folder when you play on a windows, so updating isn’t really a problem you just download the new version

PS: all you mac haters that’s why you get a mac so you don’t get trojan

When I say “The changes didn’t seem to stick”, I mean when I tried to change the engine it would just go back to the default. I haven’t ever used Wineskin, or any wrapper at all before, so I could have been doing something wrong. I got the most updated Wineskin Winery, then forced an update on the Wineskin inside Insurgence. I tried to change the engine, but there were none to choose from. I went to Wineskin Winery to download an engine (I think I got the most recent one because I couldn’t see the one they mentioned.) I went back to the Wineskin and changed the engine to the one I downloaded. I thought it did something, because it came up with the Wineskin is doing something dialogue. I opened the game, but still nothing happened. I opened the advanced setting again in the Wineskin and the engine hadn’t changed. (I deleted both Insurgence and the Wineskin Winery when I went to download it on Windows so I can’t be sure of the exact numbers.)

Porting kit did work for me though, so thank you very much for that! I feel that more attention should be brought to this Trojan virus thing though.

Edit: Now that I’ve started playing, I think there’s some music missing? In the Darkrai Cult area there wasn’t any music, and in Pokemon battles there’s the Pokemon cry but no music either. Is this the same for you?

I’ve also had issues with the music files on my mac with the most recent build. this issue wasn’t present when playing the same build on windows (on the computer I was originally playing the game on because of an issue with the old build that would crash the game often)

I tried re-downloading the most recent build, replacing the sound files with ones I knew worked on windows; nothing I did could fix the problem. my only advice is to wait for 1.2 and pray that this issue is resolved by then. I’d suggest turning off music entirely and listening to your own music playlist if the silence bothers you so much. That’s my personal work-around anyway.

Sorry that I can’t give you a better answer than this, but I’m glad to know I’m not the only one having this problem. Hopefully this gives you the same slight sense of relief as well :slight_smile:

The developers have a fix for the music for 1.2, Lunar confirmed that. The reason a lot of the music doesn’t work is that they’re .mid files which doesn’t work too well with mac, so some guy converted all of those files to .wav, however, .wav is a very large file size, so you’re gonna have to sacrifice about 700 MB to listen to music for a game that’s normally around 300 MB.

I’m basically quoting lunar from this topic, and the .wav files can be found here along with more instructions.

tl;dr: 1.2 will have music that works for sure, if you want a temporary fix that has a huge file size go to that link above ^^

It simply does not open on my mac. the message “ERROR! cannot write to Info.plist, there are permission problems, or you are on a read-only volume. This cannot run from within a read-only dmg file.” appears every time i try to play it. any ideas?

Edit: i moved the core to another folder, and the fellowing message appeared: "An error occurred while starting the X11 server: “Failed to activate core devices. Click Quit to quit X11. Click Report to see more details or send a report to Apple.” i really have no idea about whats happening.

Don’t revive a new thread about a different problem. (Try making your own wineskin wrapper, don’t reply here.)