Game not working for mac

Hey I never really download any games but this game sounded fun. I downloaded the game from this site last night and I get this message

ERROR! cannot write to Info.plist, there are permission problems, or you are on a read-only volume. This cannot run from within a read-only dmg file.

Im not very good with computers so I would very much appreciate any sort of help. Thanks.

Try dragging it onto the desktop.

It is in my desktop and its still not working.

Here are two threads that can help you(sorry, but I’m not a mac pro)

Try dragging it into Applications instead?

Tried that and got the same message.

Im assuming thats an old post. I got up to step 3 but after that It doesnt let me change the engine used. Thanks anyway though. I wish mac wouldent make it so difficult to do anything.

That’s an old post, but it still applies. However, instead of 2.6.1, you should have 2.6.2.

This is what i see. Am I missing something? https://imgur.com/a/WfJiH Thanks for the help

Yeah your wrapper is 2.5.12. In the second screen, click tools, then click update wrapper.

Ok I did that what should I do next?

Try opening the game.

Still nothing… Is there something I should have downloaded as well?