Stuck in a house

I hate to be “that guy” but I have been stuck in this house in Oranos town for ages. The Bibarel walked infront of the door, blocking me in, and hasn’t moved again since, and I’ve left my game open waiting for it to move for at least 2 hours but still nothing. I have a habit of saving way too often so I cant even use a backup save to get out of here, I’ve tried pressing P to refresh the map, I’ve tried soft resetting, restarting my whole game and even grinding the TV for rotoms but still no sign of the bibarel moving. Any help would be greatly appreciated!

A little tedious but, can you try fainting against the rotoms in the TV?

Or if you have “Restore previous versions” enabled(assuming you are on windows), try that?

Thank you very much for the fast reply, I didn’t even think about letting my pokemon faint. Just did it and it worked. Much appreciated <3

Glad it worked out.

■■■■, this just happened to me, same fucking house, can’t someone fix this?

You’re gonna have to faint via the rotoms or memory chamber, as for fixing this…

Most likely you’ll have to deal with tough luck.

I understand, I was just venting, reloaded a backup save C: