Stuck due to a bug, want help

I used tesseract in ancient ruins while pressing the up key and it made me stuck on the tesseract object, I have tried the following things to get out and none worked: toggling autorun, switching between running and cycle, trying all the quartz flute things including tesseract again, teleport, and escape rope. I also had to trade for abra with teleport etc which led to me saving multiple times in this stuck spot so old saves are also in the same place. I need suggestions to get out. Someone also said that savefile editing to move my character 1 step forward or so could work but I don’t know how to that so if someone could guide me throught that too I’d appreciate it.

give a screenshot


i just recreated the situation and i cant get out in normal ways but there is a chance to get out
IF fainted pokemon dont get healed in a trade then i can get you out of this
if u want a faster response add me on discord bagiet2

Oh wow thanks a lot I’ll add u on discord rn