Roggan Town Broken

So I was doing some dex-hunting and I realized I had to do the lottery for today. I fly to Roggan Town, and go through the casino door. There, the screen goes black and stays black no matter what I do. I can’t even quit the game, though that may be a Wine problem. (I force quitted). Unfortunately, I had also saved in Roggan Town, and when I tried to exit the map in any way (go into a building, fly, or exit to the north route, the same thing happened. Luckily, I loaded a backup and I’m not stuck in Roggan Town anymore, but I can’t go there otherwise it happens again. When I’m in Roggan Town, I can use my pokégear.

I’m on a mac, by the way. And don’t tell me the mac is the problem (looking at you cow) If anyone knows a way to fix this, posting it here would be appreciated. I haven’t posted it in the bug fixes page yet, but I will if there doesn’t seem to be a fix.

Honestly Roggan town doesn’t hold much, so I may be able to live on this, but I noticed that the PWT is in it :frowning:

Have you tried turning it off and back on again?


Do you have other saves that go up to Roggan?

I remember a similar thing happening to me a bunch of times. Closing the game and reopening it a few times (not soft resetting) seemed to solve the problem for me.

Redownloading the game works as well if I recall correctly

Oh ok I’ll try that thanks :smiley:

Ok I found a fix that worked for me.

Basically I put it into Wine instead of Wineskin by putting it into my library.