On my first playthrough on random mode, I got lopunnite for my lopunny but it wouldn’t work. Any idea why?

Where are you in the story?

I was heading to the elite four than my old laptop broke and I lost the data

Are you sure that you have the right pokemon holding it? JUST CLICK THE SPOILER!


There is a Delta Loppuny which can mega evolve.Make sure that if you have a Delta lopunny to give it a DELTA Lopunnite.

Nope I had both Delta buneary and Buneary but I never got around to evolving the delta one

Did you click the Z key that is shown if it holds the Lopunnite?

It didn’t even show the option to use it but with my Milotic and Mawile it did

You can Mega evolve only 1 team member in a battle.Maybe you already mega-evolved another pokemon from your party?

I tried to see if I did that, so I switch Lopunny to the first pokemon in my party for the next battle and it still didn’t show it but I did accidentally travel to Nara town(where you can buy Lopunnite) using hover mode while I was still on the mount rose quest, so maybe that’s why.

Try fainting it on purpose.

This worked for the Pokemon not following bug.Maybe it will help?

Well like I said in a previous post my old laptop broke so I lost that game data but thanks for the information if I have the problem ever again

Sorry this is super late, but I’m assuming this is because the Lopunny’s ability was Klutz.

I think it was