Game kinda broke

So I’ve been playing for about 2 or 3 weeks and I just beat calreath last night and saved and quit as usual. When I tried to open the game, I got an error:
Script “PokemonSystem” line 115: NoMethodError occurred. undefined method “screen size” for **:string
I have no clue what this means and I can’t open the game anymore. If anyone knows anything I can do I’d be glad to listen.

There’s also another error that shows up just before the other:
[TypeError, “incompatible marshal file format (can’t be read)\n\tformat version 4.8 required; 0.0 given”, [section059:2145:in “oldload”, “section059:2145:in “load”, “section147:75:in “pbSetUpSystem”, “section147:74:in “open”, section147:74:in “pbSetUpSystem”, “section147:263”]]

[EOFError, “End of file reached”,[section059:2145:in “oldload”, “section059:2145:in “load”, “section147:75:in “pbSetUpSystem”, “section147:74:in “open”, section147:74:in “pbSetUpSystem”, “section147:263”]]

It just does those 3 errors a few times and then closes.

-Just a bit of an update: I’ve tried downloading a second copy of the game to try and figure out the problem but the new one won’t open either and just gives me the same errors. I’ve checked the permissions and they haven’t been changed from what is required. If anything I’m now more confused about how this is happening.