App won't open on OS X Sierra

Howdy, So I just downloaded the zip file today , and surprise , surprise. It wouldn’t open. It doesn’t even prompt a popup. It’s just…there,quiet,serene. anyway this is the test run log:

_emphasized text_err:process:init_windows_dirs directory L"C:\windows" could not be created, error 2 err:process:init_windows_dirs directory L"C:\windows\system32" could not be created, error 3 err:process:init_windows_dirs directory L"C:\windows" could not be created, error 2 err:process:init_windows_dirs directory L"C:\windows\system32" could not be created, error 3 err:wineboot:main Cannot set the dir to L"C:\windows" (2) err:wineboot:ProcessRunKeys Error running cmd L"C:\windows\system32\winemenubuilder.exe -a -r" (2) err:process:init_windows_dirs directory L"C:\windows" could not be created, error 2 err:process:init_windows_dirs directory L"C:\windows\system32" could not be created, error 3 fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2 fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2 fixme:service:scmdatabase_autostart_services Auto-start service L"WineBus" failed to start: 2 wine: cannot find L"unix\Users\ve\Desktop\Pokemon Insurgence\Contents\Resources\drive_c\Program Files\Pokemon Insurgence 1.1.8\Game.exe"


I’m kinda writing a guide (WIP) so here’s part of it.

**Method One: Porting Kit**

Warning: I am very unfamiliar with this and only heard of this about a month ago. Use at your own risk. First, download Porting Kit from Download the Mac Core. Unzip and open Porting Kit, and click Library on the top of the window and click “Add Application” near the top of the window. Select the Mac Core. Now, click the Wineskin icon and click play to play the game. If you don’t trust Porting Kit or if this doesn’t work, try another method.

On to Wineskin.

**Method Two: Wineskin**

First, download Wineskin Winery from Here’s where it starts to get fun :stuck_out_tongue:. Again, we still need the Mac Core. In Finder, right-click the Core and click “Show Package Contents” then open “drive_c” then open “Program Files”. Copy the folder “Pokemon Insurgence Mac” and paste it somewhere outside of the app, like Downloads or Desktop. Now open Wineskin Winery. Make sure it says WS9Wine2.3 under “Installed Engines” and that is selected. If it isn’t highlighted, just click on it. If WS9Wine2.3 is not listed, click the plus icon underneath the “Installed Engines” box. Select WS9Wine2.3 from the drop-down menu and click “Download and Install”, and you’re up to date! Now, click “Create New Blank Wrapper”. Give whatever name you want, that’s gonna be the name of the application. Click “Cancel” when it asks to download Mono or Gecko, don’t worry about it. This might take a few minutes, so be patient. When it’s done, click “View Wrapper in Finder”. Now, right-click the application you just made and open the “Wineskin” app. Click “Install Software” and select “Move a Folder” and find the folder you made earlier and choose that. It should ask which .exe file to run, and choose Game.exe (there’s only one, so if you don’t know what to do, just click “OK”. Now go back and open the application we created, and have fun playing!


I’m assuming you downloaded the mac version of the game from the downloads page, not the straight-up exe file. In which case, the “Wine” files are included in the game itself, and should run without prior setup. If your issue is the same as the one that I faced, then here’s what I did:

Disable “rootless” on your Mac.

Rootless was something brought in with El Capitan, which wound up affecting some of the things this game requires to run. What is it? Is it important? Not really sure. I know that it marginally improves your Mac’s security, but not significantly and I haven’t had any problems since. The fix, which worked for me and which I’m pretty sure I found on this forum, is to disable it. The steps can be found here.

It is not too difficult to follow, but since you’ll need to turn off your computer to do it I recommend taking a picture of the steps on your phone, so if you forget them while performing them, it doesn’t matter - just check your picture. I don’t remember what my error message was, or if it was the same as yours, but I highly recommend doing this as it worked perfectly for me

EDIT: Try Cheese’s too obviously, I’m sure he knows more about this than me :grinning:

Oh geez, 2nd Step worked, thanks a bunch,mate! Very helpful explanation.

Got it sorted out through Cheese’s guide. Thanks for replying to the thread though!

No worries, I’m glad it worked out :grinning:

I used step 2 and this worked for me thank you!! My only question is that do I have to do this every time I want to open the game?

hi! so I followed your instructions for the second method, and did everything that the steps said but when I go to open the application it simply comes up with “This application cannot be opened” and when I tried again the application opened but nothing popped up, so my computer says the program is running but it doesn’t respond. I was wondering what I could possibly do?

@crabapple720 You’re prob not active but whatever idc about necroes at this point. You should have created an app by using that step which you can just open to keep playing

@theblackqueen hopefully you still exist. Try right clicking the app, show package contents, opening the “Wineskin” app, click advanced, and click test run. The game should open, you can quit it (no need to save logs) and open the original app like normal.

whenever i open it it says

[TypeError, "incompatible marshal file format (can’t be read)\n\tformat version 4.8 required,0.0 given,[“Section058:2139:in ‘oldload’”,“Selection058:2139:inload'","Section146:75:inpbSetUpSystem’”,“Section146:74:in open'","Section146:74:inpbSetUpSystem’”,“Section146:227”]]

i already played a bunch so i would prefer if i could keep my save files but i’d be happy just to play again

also i’m on windows please help