Any way to get rid of screen tearing?

Started playing yesterday, but getting pretty bad screen tearing. I’ve looked around quite a bit regarding this issue, and it seems like it’s a problem with RPG Maker XP itself, something about its framerate cap and not using the GPU or something?

Here are my laptop’s specs:

  • MSI-GE40 2OC laptop
  • Intel Core i7-4702MQ CPU
  • Nvidia GeForce GTX 760M GPU
  • 8 GB of RAM
  • Windows 8.1

And here are the things I’ve tried to fix the screen tearing, none of which worked: Forcing Vsync in Nvidia Control Panel, both globally and for the Game.exe itself. Setting Vsync to driver settings in Intel Graphics HD Control Panel. Forcing the game to run using either the Nvidia GPU or the integrated Intel GPU. Running the game in all screen sizes, including fullscreen. Running the game in compatibility modes for Windows XP, Vista, and 7. Using D3DOverrider to force Vsync, both globally and for the Game.exe itself. (Couldn’t adjust monitor refresh rate, as my monitor doesn’t support that.)

So yeah, I’m just about out of ideas on what to do, and Google hadn’t turned up any useful results either. Did anyone else have screen tearing, and if so, did you manage to fix it?

1 Like

Are you using large screen size option?

In the list of things I tried, I said that I tried all of the screen sizes. All of them have really bad screen tearing, though it’s more noticeable on larger screen sizes.