A fresh reinstall help stop lag in Insurgence?

I made a post asking for help solving my lag issue in the game. The title is Pokemon Insurgence not running efficiently.

I have tried tons of things to no avail. I was wondering if I did a fresh reinstall of my computer if that would help? Looking for some invoice or info of people trying this method. Don’t want to do it if I don’t have to or it don’t solve the issue.

Just went through your previous post again.

The lag spike of just the HP and exp bars decreasing/increasing, that’s how the software the game was made with works :frowning:

  • If you’re using any 3D sprite pack, that’s been known to cause lag for quite a few people. Try playing with just the default download.

  • If you’re not using any 3D sprite pack, try playing around with the different text speed as well as turbo speed settings in the options before backing up your saves, deleting and then redownloading the core.

  • Fiddling around the first two options when you press F1(or Fn+F1), turning off the battle effects in options, deselecting smooth mode etc,. Basically playing with lowest graphics settings.

The above worked only for one or two people, most people who reported sudden lag similar to yours(about 20ish people since the game was first released) despite having good computers couldn’t find a solution.

To answer this post’s question, a fresh install of Windows itself didn’t work for the 2 people I know who tried it though.

Sorry I can’t help you more :sad:

You helped more than you know and thank you. I will bypass the fresh install. I DID notice a slight better perfomance having it on the medium sized window (one below large). I do not use a 3D sprite pack. I will do some more finagling and see if it ends up working itself out :slight_smile:

Well good news. I did not reinstall windows however playing on the medium window has helped. When I do go to full screen it does act up and it occasionally acts up in medium size but its playable for sure.

Have a feeling though that the speed up thing isn’t going as fast as it can go. I may be wrong but there is speed up.

These are the options I am running:

-text at insane speed

-battle scene on

-shift battle style

-Frame 1

-Speech frame 2 (not sure if these truly matter)

-font style EM

-Screen size Med

-Music Volume 66

-Sound Volume 51

-Stat change Overlay On

-Difficulty Normal

-Turbo Speed Ludicrous

-Purity Mode OFF

Constant Daytime OFF

Story Darker

Hopefully people who see this hopefully find it useful! However I would love to find a way to play the game fullscreen like before with no hiccups.

Welp, at least you found a temporary workaround.