Site Downloads Wiki Bugs Discord Battling

Repair installation + Play error


#1

Yep, I’m still trying to update my game. After issues with the launcher, rar openers, and pretty much everything under the sun, I tried one last time to download through the launcher. By some miracle, it fully downloaded and installed that way. However, when I went to click play, it said that there was some sort of error and it reccomended I repair the installation. At this point, I think my laptop is delebrately trying to drive me crazy.

Anyway, it seems to be downloading fine at the moment. I really don’t want to download any more openers that add unnessisary clutter to my laptop, should this issue be solved when it fully re-downloads, or will this entire process repeat itself?


#2

After loading the game again, this it happened again!!! I’m so frustrated! What on earth can I do about it?


#3

(I’m not expert, but I’ll take a stab at it)

You’re computer doesn’t have all the fonts Pokemon Insurgence needs to run. Go to the Fonts folder, and paste those fonts to where fonts are stored in your computer. (A simple search on google should give you the location.)


#4

According to the first message, the fonts shouldn’t effect the way the game runs.(I appreciate the effort, though.) I’m also currently using the launcher. These are also two separate errors I’ve been getting. (Sorry if that confused you.) Do you think installing the fonts would still fix the issue?


#5

It’s worth a try.


#6

You’re right. But how would you (If possible.) fix that with the launcher?


#7

Uh, fix what? The launcher is just a way for people to download the latest core easily.


#8

I’ve been getting these errors from the launcher. This happened before, so I tried to repair the installation, since it was suggested. Despite the fact that I’ve supposedly completed the download and installation with no interruption, I still have this problem, even on my second attempt.


#9

Ah, so you’re not able to even download it, the launcher itself isn’t working?


#10

It’s supposedly downloaded fully, so yes. Do you know if deleting and re-downloading the launcher will fix this issue? I realize the launcher itself hasn’t been updated along with the game itself, but I’m wondering if you think it could just be a problem my specific launcher has. (I was able to run the game fine when it was at 1.8, I don’t understand why )


#11

I’m sorry, but if it’s for the launcher I’m stumped. Re-downloading the launcher probably wouldn’t do anything. If you can, download the 1.2 core(no launcher) and wait for the official 1.2.3 patch either today or tomorrow.


#12

That’s what I was afraid of. I’ve tried downloading several rar openers, with no luck. I’m willing to keep trying. One more question- if I’m able to run the core, save the game in the updated version, then delete and re-download the launcher, should it be updated then? (I’d rather not download even more potentially virus-ridden programs to apply the patch.)


#13

Use 7-Zip. The launcher should automatically download 1.2.2, I believe, no matter what version of the game you’re playing.


#14

Thanks, but I still need a bit of help. (I’m sorry if I’m a bother.) I downloaded 7-Zip, but it won’t let me open the core I downloaded from the mirror file. Is this the wrong version, or is there something else I did wrong? I believe that the core is a complete download.

About the updated launcher idea, I looked at thread when I was having a different problem earlier, where that is provided as a fix.

I still might give it a try if it comes to that.


#15

Previously I have played on the 1.1.7 and 1.1.8 versions of the game and I’ve been able to patch and update them just fine, but the move to 1.2.0 is troubling me. I managed to download and install the new core but when I open the game an error message pops up saying:

Script ‘HM7 NEW CLASSES’ line 41: RuntimeError occurred. Load Library: MGC_Hmode7

What do I need to do to fix this problem, and load my previous save files?


#16

I’m having the same problem. It started with the fonts being missing, but once I installed the fonts I got the exact same error. Please help.


#17

@Birdsteeth sorry for the late reply, that error indicates an incomplete download/extraction. Things you can try would be

  • Redownload new core from mirror or torrent linked in this post (assuming you’re on windows since this thread is about launcher)

  • Make sure the extraction program you’re using is up-to-date.

  • Using a different extraction program, (WinZip or 7-Zip and if neither works, then try WinRar or others).

If you’re on windows, the save file is located in a different directory so you don’t need to transfer it manually.

@RandomAI Try the steps above