Won't start

I have the game downloaded but when I press start nothing happens. Do I need an emulator or something similar?

Tried to relaunch the game starter and everytime i do it says that im missing some required files and that i need to redownload.

It does take quite some time to start so how long did you wait?

Not much so I’ll try again and wait like 5 minutes and see if it works

Waited a long time. Still nothing.

Have you extracted all the files from the ZIP folder?

After downloading the zip file, make sure that you’ve extracted the game, this can be done using an extration program such as Winrar or 7zip. After this, open Game.exe, it should have a sun icon.

If the black screen persists, right click Game.exe and select Run as Administrator to run the game as an admin. If this still doesn’t work, try adding a DEP (Data Execution Prevention) exception.

  • Open Control Panel
  • Search for Advanced System Settings
  • Click the only result (should have a shield icon iirc)
  • Go to Advanced
  • First option should say Performance, click Settings, this opens a new window
  • Go to Data Execution Prevent
  • Click the “Add…” button
  • Add the game executable
  • Press apply/OK, restart the game