Stuck in Amphitrite City

I’m in Amphitrite city now and, after talking to Calreath, I got stuck. I don’t know how to move on. Seriously, I can’t find him, I’ve tried anywhere! (Mt.Rose Base, the cave in the south). Any suggestion? Is there anything I have to do first? Thx!

You have to use Tessaract in the cave in the south to advance. Try a few things, then if youre still stuck let me know and I’ll be more detailed.

Thank you! I’m here in the cave, used the tesseract, but still I have no idea on how to move the boulders on the path or to advance in other ways. Any clue?

You can just push the boulders around, no?

Please post a screenshot of where you are if you want more specific advice

Where do you even meet up with the gym leader and his friend after the initial meeting(as in when he tells you and nora to go meet his friend and that they are on the same side) ? I searched the entire town, cave and the base but I could not find them

I am having the same problem.

There are no movable blocks after using tessarect and both exits are blocked (because of the rocks). The only thing I found after using Tessarect was a full restore. Let me know if you need any further information!

I will add screenshots in a few minutes.

EDIT: http://imgur.com/LG4ntam (pre tessarect) http://imgur.com/3pTfHrX (post tessarect 1) http://imgur.com/SRj3Pqk (post tessarect 2)

@Cow538 Could you take a look at this? (I was not certain if you would receive a message without this tag :sweat_smile: )

I have the same problem. I think this is one of the location bugs or stuck areas that’s going around. We should just wait for the upcoming patch

use terrasect in the cave then move right below the small cliff use terrasect close to that flaming ball

2 Likes

@tomiks1 you were right! Problem solved! I thought you could not use tesseract outside the glowing area (just like the pic), but I was wrong! Thank you all!